Konu Araçları | Seçenekler: | Gösterim Stili
Tarih
14/04/2011 14:41
Konu Sahibi
AhmetSedat
Yorumlar
2
Okunma
2525
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 5
  • 4
  • 3
  • 2
  • 1

Derecelendirme: 0/5 - 0 oy

AhmetSedat

Üye
Kullanici Avatari
Üye
1
1
19/02/2011
0
Bursa
Ofis 2003
17/04/2011,17:59
Çözüldü 
Merhaba değerli arkadaşlar.
Projemde kullandığım formüllerin R[1]C[1] karşılığını makro kaydet yöntemi ile alarak ComboBox1_Change() yordamında kullanmaktayım.
Sizlerden ricam; Fazla mesai sayfasında C4:AG4 hücresinde kullanılan aşağıdaki formülünün R[1]C[1] karşılığını makro kaydet yöntemi ile yapamıyorum.

Visual Basic Code
1
2
3
4
5
6
7
8
9
10
11
12
13
Private Sub ComboBox1_Change()
If ComboBox1 <> "" Then
'On Error Resume Next
[A4:AG39].Value = ClearContents
[A1].Value = "=CONCATENATE(PERSONEL!RC[4],""  "",TEXT(" & ComboBox1.Value & "!R[1]C[1],""AAAA YYYY ""),""İCAP MESAİ BİLDİRİM ÇİZELGESİ"")"
[A4:A39].Value = "=IF(" & ComboBox1.Value & "!RC[10]="""",""""," & ComboBox1.Value & "!RC[11])"
[B4:B39].Value = "=IF(RC[-1]="""","""",VLOOKUP(RC[-1],PERSONEL!R[-2]C[-1]:PERSONEL!R[15]C,2,0))"
[color=#FF0000][C4:AG39].Value =?[/color]
[C3].Value = "=" & ComboBox1.Value & "!R2C2"
[D3:AG3].Value = "=" & ComboBox1.Value & "!R2C2+COLUMN(R[-2]C[-3])"
[AH4:AH39].Value = "=SUM(RC[-31]:RC[-1])"
End If
End Sub


Kod:
=EĞER($A4="";"";EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34=C$3))=0;"";EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34<=C$3))=7;8;EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34<=C$3))>7;24;""))))




Ek Dosyalar
.rar   Ornek.rar (Dosya Boyutu: 39,08 KB / İndirme Sayısı: 25)
Cevapla

DUAYEN

Aktif Üye
Kullanici Avatari
Aktif Üye
S.... A....
1.026
13/08/2010
279
Yozgat
Ofis 2007
16/03/2017,17:22
Çözüldü 
Konuyu biraz daha açarmısınız örnek vererek dosyayı tekrar ekleye bilirmisiniz.


Cevapla

benremix

Uzman
Kullanici Avatari
Uzman
R.... S....
4.433
17/05/2009
365
Ankara
Ofis 2010
Bugün,05:31
Çözüldü 
Konuya dönüş olmadığından, konu taşınmıştır.


Bilgi paylaşıldıkça çoğalır....
Her engel, yaşam koşullarınızı daha iyileştirecek bir fırsattır.


Access için her zaman lazım olacak konu başlıkları listesi


Cevapla


Konuyu Okuyanlar: 1 Ziyaretçi

[-]
Etiketler
kaydet ile formülü çeviremiyorum şekline r1c1 makro


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Tarih Son Yorum
Çözüldü Dosyayı Farklı Kaydet - kaydet - kopya oluştur husem 2 282 18/03/2017, 00:34 husem
Çözüldü Excel'de Makro Ya Da Modülde Düzenleme Yapma mehami 2 327 24/02/2017, 10:57 mehami
Çözüldü A hücresindeki değer B hücresindeki değerden küçükse c hücresine bu formülü uygula simendifer 6 999 19/02/2017, 10:51 atoz112
Çözüldü Makro İle Çoklu Satır Taşıma boraday 9 3.103 05/01/2017, 17:18 turankr
Çözüldü makro ile excele veri almak siyahhayis 4 1.793 05/06/2016, 15:48 atoz112

Türkçe Çeviri: MCTR, Yazılım: MyBB, © 2002-2017 MyBB Group.
Forum use Krzysztof "Supryk" Supryczynski addons.