Konu Araçları | Seçenekler: | Gösterim Stili
Tarih
08/07/2010 17:41
Konu Sahibi
canlaracan
Yorumlar
7
Okunma
3678
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 5
  • 4
  • 3
  • 2
  • 1

Derecelendirme: 0/5 - 0 oy

canlaracan

Üye
Kullanici Avatari
Üye
C.... C....
14
4
28/11/2008
0
İzmir
Ofis 2007
07/08/2017,14:14
Çözüldü 
Bir çalışma kitabında yaklaşık 21 sayfa açtım ve yine her dört sayfa bir başka bölüme (örnekte 8A,8B,7A,7B şeklinde sayfaya bağlanıyor) ilk farklı 4 sayfadaki (sayfa1A, sayfa2A,sayfa3A,sayfa4A,) Sayfalarındaki H4 hücresine girilen aynı ismi (örneğin: can başka bir sayfada yazdırmak istiyorum, yani 7a sayfasında b2 hücresine isim olarak yazdırmak istiyorum. örnek olarak dosyayı gönderiyorum; 1a,2a,3a,4a hücreleri renkli olan hücreye yazılan aynı ismi örnek "can" (dört hücreye de aynı isim olacak yada en azından bir hücreye bir kez yazılacak) bu yazılan isimler '7A' sayfasında 1b2' hücresine bu dört isimden biri yazılacak yada dört hücreye girilen aynı isimden bir yada iki aynı isimden biri yazılacak ; yada h4 hücresine girilen üç aynı isimden biri '7A' sayfasında 1b2' hücresine yazılacak; 1b 2b 3b 4b sayfalarındaki h4 hücresi için de aynı şeyler '8b' sayfası içinde geçerli
dosyayı ekte gönderdim.

Bu nu nasıl yapabilirim
şimdiden teşekkürler


Ek Dosyalar
.rar   aynı isimleri tek hücrede bir kez yazdırma.rar (Dosya Boyutu: 29,48 KB / İndirme Sayısı: 10)
Cevapla

ogulcan92

Aktif Üye
Kullanici Avatari
Aktif Üye
1.159
06/05/2009
477
İzmir
Ofis 2003
07/08/2015,11:50
Çözüldü 
Sn:Can Gül
Sorunuzu 07-07-2010, 07:34 tarihinden beri defalarca okumama rağmen hiç birşey anlamadım.Ne yapmak istediğini tane tane heyecanlanmadan açıklarmısın.Dosyanızdanda herhangi birşey anlaşılmıyor.


Cevapla

canlaracan

Üye
Kullanici Avatari
Üye
C.... C....
14
4
28/11/2008
0
İzmir
Ofis 2007
07/08/2017,14:14
Çözüldü 
(08/07/2010, 18:26)ogulcan92 Adlı Kullanıcıdan Alıntı: Sn:Can Gül
Sorunuzu 07-07-2010, 07:34 tarihinden beri defalarca okumama rağmen hiç birşey anlamadım.Ne yapmak istediğini tane tane heyecanlanmadan açıklarmısın.Dosyanızdanda herhangi birşey anlaşılmıyor.


1a 2a 3a 4a şeklinde çalışma sayfamız var. ve bu sayfalardaki h4 hücresine aynı ismi yazıyoruz.yada dört sayfadaki h4 hücresine bir kez bir isim yazıyoruz diğer üç sayfadaki h4 hücresine yazmıyoruz veya iki sayfadaki h4 hücresine aynı ismi yazıp diğer 2 sayfadaki h4 hücresini boş olabilir.Yani seçenekli bir durum.tüm bu sayfalardaki hücre bilgileri başka bir sayfada yani 7a sayfasında ve b2 hücresinde birkez yazılacak.örneğin dört sayfada 'can' ismini 3 kez kullandıksak 7a sayfasında b2 hücresinde bir kez yazılacak
umarım açıklayabilmişimdir.
ilginiz içind teşekkürler


Cevapla

ogulcan92

Aktif Üye
Kullanici Avatari
Aktif Üye
1.159
06/05/2009
477
İzmir
Ofis 2003
07/08/2015,11:50
Çözüldü 
Sn:Can Gül
İstediğiniz bu şekilde idi sanırım, sorunuzdan anlaya bildiğim kadarı ile yapmaya çalıştım.

Formül ile:

PHP Kod:
=EĞER('1A'!H4="";EĞER('2A'!H4="";EĞER('3A'!H4="";EĞER('4A'!H4="";"";'4A'!H4);'3A'!H4);'2A'!H4);'1A'!H4)


Makro ile:7A sayfasında kod bölümüne yazılacak.

Kod:
1
2
3
4
5
6
Private Sub Worksheet_Activate()
Range("B2:C2").Select
    ActiveCell.FormulaR1C1 = _
        "=IF('1A'!R4C8="""",IF('2A'!R[2]C[6]="""",IF('3A'!R[2]C[6]="""",IF('4A'!R[2]C[6]="""","""",'4A'!R[2]C[6]),'3A'!R[2]C[6]),'2A'!R[2]C[6]),'1A'!R4C8)"
    Range("A3:B3").Select
End Sub


Ek Dosyalar
.rar   aynı isimleri tek hücrede bir kez yazdırma.rar (Dosya Boyutu: 36,42 KB / İndirme Sayısı: 8)
Cevapla

canlaracan

Üye
Kullanici Avatari
Üye
C.... C....
14
4
28/11/2008
0
İzmir
Ofis 2007
07/08/2017,14:14
Çözüldü 
sayın Oğulcan Olcaytuğ arkadaş
öncelikle çok teşekkür ederim
=EĞER('1A'!$H$4="";EĞER('2A'!H4="";EĞER('3A'!H4="";EĞER('4A'!H4="";"";'4A'!H4);'3A'!H4);'2A'!H4);'1A'!$H$4) şeklinde oluyor ancak
"okul_raporu" sayfasında f3 hücresinde =TOPLA('8A'!$E$2;'8B'!$E$2;'7A'!$E$2;'7B'!$E$2) yaptırıyorum. Ancak daha önce 7a sayfasında boş görüne B2 hücresine başvurup D2 hücresine =EĞER(EBOŞSA(B2);"0";"1") formülünü yazıyorum. Sonrada D2 hücresine başvurup; E2 =SAYIYAÇEVİR(D2)formülünü giryorum.ve daha sonrada "okul_raporu" sayfasında f3 hücresinde =TOPLA('8A'!$E$2;'8B'!$E$2;'7A'!$E$2;'7B'!$E$2) yaptırıyorum burada formülün altı çizili ve siyah olan kısmı boş olduğuna göre toplamda 3 çıkması gerekirken 4 çıkıyor. bunu nasıl düzeltebilirim
sayın Oğulcan Olcaytuğ arkadaş cevap için öncelikle teşekür ederim
Teşekkürler


Cevapla

ogulcan92

Aktif Üye
Kullanici Avatari
Aktif Üye
1.159
06/05/2009
477
İzmir
Ofis 2003
07/08/2015,11:50
Çözüldü 
Sn:Can Gül
Aslında ilk soruyu sorduğun zaman yazmış olduğun formülde doğru yoldaymıssın orada yazdığın YADA işi karıştırmış, birde mesaj yazarken aynı kelimeleri tekrarladığın için çok karışıyor.7A sayfasındaki D2 hücresine aşağıdaki formülü giriniz.

Not:4 Nolu mesajdaki eklenti güncellenmiştir.

Kod:
=EĞER(B2="";0;1)


Cevapla


Konuyu Okuyanlar: 1 Ziyaretçi

[-]
Etiketler
içindeki başka ismi hücre dört sayfada sayfadaki ayrı bir


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Tarih Son Yorum
Çözüldü VBA Excel'de Instr ile belirli hücre değerleri haricindekiler varsa işlem yapma balkan85 7 1.453 07/10/2016, 14:56 balkan85
Çözüldü Ödeme durumuna göre Hücre renklendirme (Koşullu Biçimlendirme) omerozel25 8 1.096 20/08/2016, 18:11 atoz112
Çözüldü Hücre boş geçerse mesaj ver ozkovlu29 9 1.085 19/08/2016, 08:49 ozkovlu29
Çözüldü Hücre Gizle-Göster ozkovlu29 2 688 19/08/2016, 08:48 ozkovlu29
Çözüldü Barkod okutulduğunda bilgilerin sayfada gösterilmesi karanfiloy 8 995 03/08/2016, 00:49 karanfiloy

Türkçe Çeviri: MCTR, Yazılım: MyBB, © 2002-2017 MyBB Group.
Forum use Krzysztof "Supryk" Supryczynski addons.