Çoklu ifade YARDIM Ricası
Tarih
05/06/2013 23:49
Konu Sahibi
gravesac
Yorumlar
3
Okunma
869
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 5
  • 4
  • 3
  • 2
  • 1

Derecelendirme: 0/5 - 0 oy



Çözüldü 
Sponsor Reklam
daha önceden excelde yaptığım tabloyu Access te yapmaya çalışıyorum. Ancak excelde
EĞER(VE(hc1<12;hc2<30);4;EĞER(VE(hc1<12;hc2>=30);6;0)) tarzındaki ifadeleri Access te yapamadım. yardımcı olabilirseniz çok sevinirim, denemelerimden biri aşağıda;

IIf(([yas]<12 And [kanbasıncı]<30;4;iif([yas]<12and[kanbasıncı]>=30;6;0))

amaç= 12 yaş altında kanbasıncı 30 dan küçükse 4, 12 yaş altında kanbasıncı büyükeşit 30 ise 6 diğer yaşlar ve kanbasınçları için 0 değeri alsın istiyorum. (gerçi diğer yaşlar içinde farklı değerler var ama bu kısımda yardımcı olursanız gerisini halledebilirim diye umuyorum.[/quote]
Cevapla

Kur@l
AccessTR.Net
Kullanici Avatari
Uzman
2.031
05/11/2008
KONYA
Ofis 2010
13/02/2017,14:56
Çözüldü 
Örneğinizi Ekleyiniz.
komşuda dülger mi var geliyor keser sesi,
ustalar konuşunca çıraklar keser sesi.
Cevapla

Çözüldü 
Sponsor Reklam
deneme amacıyla yaptığım Access tablosunu ekliyorum, içindepuan1,puan2 puan3 isimli denemelerim mevcut.

Buda excelde yapıp accesste yazmaya çıştığım ifadelerden biri..

Visual Basic Code
=EĞER(VE(B2=0;B3<40);7;EĞER(VE(B2=0;B3>=40;B3<55);3;EĞER(VE(B2>=1;B2<13;B3<45);7;EĞER(VE(B2>=1;B2<13;B3>=45;B3<65);3;EĞER(VE(B2>12;B2<120;B3<55);7;EĞER(VE(B2>12;B2<120;B3>=55;B3<75);3;EĞER(VE(B2>=120;B3<65);7;EĞER(VE(B2>=120;B3>=65;B3<85);3;0))))))))


teşekkürler..



Ek Dosyalar
.rar   deneme.rar (Dosya Boyutu: 19,47 KB / İndirme Sayısı: 7)
Cevapla

ozanakkaya
sledgeab
Kullanici Avatari
Kurucu
O.... A....
9.315
29/01/2008
Denizli
Ofis 2010 32 Bit
Bugün,18:26
Çözüldü 

SQL Code
iif(([puan2]=0 and [puan3]<40);"7";iif(([puan2]=0 and [puan3]>=40 and [puan3]<55);"3";iif(([puan2]>=1 and [puan2]<13 and [puan3]<45);"7";iif(([puan2]>=1 and [puan2]<13 and [puan3]>=45 and [puan3]<65);"3";iif(([puan2]>12 and [puan2]<120 and [puan3]<55);"7";iif(([puan2]>12 and [puan2]<120 and [puan3]>=55 and [puan3]<75);"3";iif(([puan2]>=120 and [puan3]<65);"7";iif(([puan2]>=120 and [puan3]>=65 and [puan3]<85);"3";0))))))))


Cevapla


Konuyu Okuyanlar: 1 Ziyaretçi


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Tarih Son Yorum
  çoklu seçmeli sorgu murat_orh 16 176 05/02/2017, 11:37 atoz112
  Kullanıcı Yetkilendirme Konusunda Yardım arasson 8 185 03/02/2017, 11:35 arasson
  Access Vba Kodsuz Veri Doğrulama Yardım !!! karakule31 4 171 20/01/2017, 20:02 karakule31
  ÜRETİM TAKİP PROGRAMI TABLO GİRİŞİ FAZLA YARDIM LÜTFEN cturkyilmaz 11 340 12/01/2017, 18:27 ozanakkaya
  YARDIM EDER MİSİNİZ Halil Çal 1 115 04/01/2017, 12:55 ozguryasin


Türkçe Çeviri: MCTR, Yazılım: MyBB, © 2002-2017 MyBB Group.
DMCA.com Protection Status
© Desing by XSTYLED| Develops by ozanakkaya