Formülü makro kaydet ile R1C1 şekline çeviremiyorum.
Tarih
14/04/2011 14:41
Konu Sahibi
AhmetSedat
Yorumlar
2
Okunma
2213
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 5
  • 4
  • 3
  • 2
  • 1

Derecelendirme: 0/5 - 0 oy



AhmetSedat
Üye
Kullanici Avatari
Üye
1
1
19/02/2011
0
Bursa
Ofis 2003
17/04/2011,17:59
Çözüldü 
Sponsor Reklam
Merhaba değerli arkadaşlar.
Projemde kullandığım formüllerin R[1]C[1] karşılığını makro kaydet yöntemi ile alarak ComboBox1_Change() yordamında kullanmaktayım.
Sizlerden ricam; Fazla mesai sayfasında C4:AG4 hücresinde kullanılan aşağıdaki formülünün R[1]C[1] karşılığını makro kaydet yöntemi ile yapamıyorum.

Visual Basic Code
1
2
3
4
5
6
7
8
9
10
11
12
13
Private Sub ComboBox1_Change()
If ComboBox1 <> "" Then
'On Error Resume Next
[A4:AG39].Value = ClearContents
[A1].Value = "=CONCATENATE(PERSONEL!RC[4],""  "",TEXT(" & ComboBox1.Value & "!R[1]C[1],""AAAA YYYY ""),""İCAP MESAİ BİLDİRİM ÇİZELGESİ"")"
[A4:A39].Value = "=IF(" & ComboBox1.Value & "!RC[10]="""",""""," & ComboBox1.Value & "!RC[11])"
[B4:B39].Value = "=IF(RC[-1]="""","""",VLOOKUP(RC[-1],PERSONEL!R[-2]C[-1]:PERSONEL!R[15]C,2,0))"
[color=#FF0000][C4:AG39].Value =?[/color]
[C3].Value = "=" & ComboBox1.Value & "!R2C2"
[D3:AG3].Value = "=" & ComboBox1.Value & "!R2C2+COLUMN(R[-2]C[-3])"
[AH4:AH39].Value = "=SUM(RC[-31]:RC[-1])"
End If
End Sub


Kod:
=EĞER($A4="";"";EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34=C$3))=0;"";EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34<=C$3))=7;8;EĞER(TOPLA.ÇARPIM(--(OCAK!$C$4:$I$34=$A4)*(OCAK!$C$3:$I$3="nöbet")*(OCAK!$A$4:$A$34<=C$3))>7;24;""))))






Ek Dosyalar
.rar   Ornek.rar (Dosya Boyutu: 39,08 KB / İndirme Sayısı: 25)
Cevapla

DUAYEN
Aktif Üye
Kullanici Avatari
Aktif Üye
S.... A....
1.026
13/08/2010
279
Yozgat
Ofis 2007
28/10/2016,11:41
Çözüldü 
Konuyu biraz daha açarmısınız örnek vererek dosyayı tekrar ekleye bilirmisiniz.
Cevapla

benremix
Uzman
Kullanici Avatari
Uzman
R.... S....
4.432
17/05/2009
365
Ankara
Ofis 2010
Bugün,08:14
Çözüldü 
Sponsor Reklam
Konuya dönüş olmadığından, konu taşınmıştır.
Bilgi paylaşıldıkça çoğalır....
Her engel, yaşam koşullarınızı daha iyileştirecek bir fırsattır.


Access için her zaman lazım olacak konu başlıkları listesi 


Cevapla


Konuyu Okuyanlar: 1 Ziyaretçi


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Tarih Son Yorum
Çözüldü Makro İle Çoklu Satır Taşıma boraday 9 2.247 05/01/2017, 17:18 turankr
  A hücresindeki değer B hücresindeki değerden küçükse c hücresine bu formülü uygula simendifer 3 199 28/11/2016, 14:51 simendifer
  makro ile excele veri almak siyahhayis 4 896 05/06/2016, 15:48 atoz112
  makro vba devre dışı hatası fehmikonkur 5 634 16/05/2016, 17:03 atoz112
Çözüldü Makro kayıt sorunu sebo44 2 323 14/04/2016, 14:36 sebo44


Türkçe Çeviri: MCTR, Yazılım: MyBB, © 2002-2017 MyBB Group.
DMCA.com Protection Status
© Desing by XSTYLED| Develops by ozanakkaya