Çoklu ifade YARDIM Ricası
Tarih
05/06/2013 23:49
Konu Sahibi
gravesac
Yorumlar
3
Okunma
857
Konuyu Oyla:
  • Derecelendirme: 0/5 - 0 oy
  • 5
  • 4
  • 3
  • 2
  • 1

Derecelendirme: 0/5 - 0 oy



Çözüldü 
Sponsor Reklam
daha önceden excelde yaptığım tabloyu Access te yapmaya çalışıyorum. Ancak excelde
EĞER(VE(hc1<12;hc2<30);4;EĞER(VE(hc1<12;hc2>=30);6;0)) tarzındaki ifadeleri Access te yapamadım. yardımcı olabilirseniz çok sevinirim, denemelerimden biri aşağıda;

IIf(([yas]<12 And [kanbasıncı]<30;4;iif([yas]<12and[kanbasıncı]>=30;6;0))

amaç= 12 yaş altında kanbasıncı 30 dan küçükse 4, 12 yaş altında kanbasıncı büyükeşit 30 ise 6 diğer yaşlar ve kanbasınçları için 0 değeri alsın istiyorum. (gerçi diğer yaşlar içinde farklı değerler var ama bu kısımda yardımcı olursanız gerisini halledebilirim diye umuyorum.[/quote]
Cevapla

Kur@l
AccessTR.Net
Kullanici Avatari
Uzman
2.029
05/11/2008
KONYA
Ofis 2010
Bugün,02:22
Çözüldü 
Örneğinizi Ekleyiniz.
komşuda dülger mi var geliyor keser sesi,
ustalar konuşunca çıraklar keser sesi.
Cevapla

Çözüldü 
Sponsor Reklam
deneme amacıyla yaptığım Access tablosunu ekliyorum, içindepuan1,puan2 puan3 isimli denemelerim mevcut.

Buda excelde yapıp accesste yazmaya çıştığım ifadelerden biri..

Visual Basic Code
=EĞER(VE(B2=0;B3<40);7;EĞER(VE(B2=0;B3>=40;B3<55);3;EĞER(VE(B2>=1;B2<13;B3<45);7;EĞER(VE(B2>=1;B2<13;B3>=45;B3<65);3;EĞER(VE(B2>12;B2<120;B3<55);7;EĞER(VE(B2>12;B2<120;B3>=55;B3<75);3;EĞER(VE(B2>=120;B3<65);7;EĞER(VE(B2>=120;B3>=65;B3<85);3;0))))))))


teşekkürler..



Ek Dosyalar
.rar   deneme.rar (Dosya Boyutu: 19,47 KB / İndirme Sayısı: 7)
Cevapla

ozanakkaya
sledgeab
Kullanici Avatari
Kurucu
O.... A....
9.182
29/01/2008
Denizli
Polis Memuru
Ofis 2010 32 Bit
Çözüldü 

SQL Code
iif(([puan2]=0 and [puan3]<40);"7";iif(([puan2]=0 and [puan3]>=40 and [puan3]<55);"3";iif(([puan2]>=1 and [puan2]<13 and [puan3]<45);"7";iif(([puan2]>=1 and [puan2]<13 and [puan3]>=45 and [puan3]<65);"3";iif(([puan2]>12 and [puan2]<120 and [puan3]<55);"7";iif(([puan2]>12 and [puan2]<120 and [puan3]>=55 and [puan3]<75);"3";iif(([puan2]>=120 and [puan3]<65);"7";iif(([puan2]>=120 and [puan3]>=65 and [puan3]<85);"3";0))))))))


Cevapla


Konuyu Okuyanlar: 1 Ziyaretçi


Konu ile Alakalı Benzer Konular
Konular Yazar Yorumlar Okunma Tarih Son Yorum
  YARDIM EDER MİSİNİZ Halil Çal 1 69 04/01/2017, 12:55 ozguryasin
  Listede farklı bir tabloyu çoklu ölçüt olarak kullanmak. nightashes 2 111 01/01/2017, 01:05 nightashes
  iki tablo arasında girilen veriyi ikinci tabloda alan olarak oluşturma yardım bilservisci 8 244 15/12/2016, 11:49 atoz112
  İfade türü uyuşmazlığı nightashes 3 88 05/12/2016, 19:07 nightashes
  Sorgudan ifade alanını forma aldırma yenginoglu 2 126 10/11/2016, 01:34 yenginoglu


Türkçe Çeviri: MCTR, Yazılım: MyBB, © 2002-2017 MyBB Group.
DMCA.com Protection Status
© Desing by XSTYLED| Develops by ozanakkaya